Eclipse 3.2 M6 is now available

The noteworthy posting can be found here. There is some good stuff in this and one potential problem for any developers who used extension ID’s with periods in them. (ie. com.ibm.rcp.myId). Starting in M6 the concept of providing ID’s under other namespaces is now possible. So if your plugin uses this convention, make sure the ID’s are in the correct namespaces in order to be processed.

Plug-in manifest files generated by PDE now contain a new processing instruction indicating version 3.2, instead of 3.0. This new processing instruction is required if a plug-in is to take advantage of the new runtime support where a plug-in can contribute extension points and extensions to a namespace other than its own.


Download Eclipse 3.2 M6 here.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.